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Module 2 

Using the Computer and 
Managing Files 
Module Overview 

Welcome to Module 2: Using the Computer and Managing Files. 

In this module you will be introduced to Ubuntu Linux Operating 
System (version 9) with Gnome desktop environment. 

 

 

Upon completion of this module you will be able to: 

 Use the main features of the operating system including adjusting 
main computer settings and using built-in help features. 

 Operate effectively around the computer desktop and work 
effectively in a graphical user environment. 

 Understand the main concepts of file management and be able to 
efficiently organise files and folders so that they are easy to 
identify and find. 

 Use utility software to compress and extract large files and use 
anti-virus software to protect against computer viruses. 

 Demonstrate the ability to use simple text editing and print tools 
available within the operating system. 

 Set up a printer in Ubuntu and use the Print Manager utility to 
monitor, cancel, pause and resume printing. 

Terminology 

 

 

GNOME Desktop The graphical user interface for the Ubuntu 
operating system. 

Operating System An interface between the computer hardware and 
the computer user. It is the software program 
responsible for the management of activities and 
the sharing of resources of a computer. 
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 Ubuntu Ubuntu is an African word meaning “Humanity to 
others” or “I am what I am because of who we all 
are”. It is also a community-developed operating 
system based on Linux. 

Window A rectangular area of the screen that displays an 
application running on your system. 

Mounting and 
Unmounting  

The process of adding and removing components 
to the Linux directory hierarchy. 

Home directory When a new user is added to the system, Linux 
creates a sub-directory of the same name in the 
home directory. This sub-directory is known as the 
user’s home directory. 

Panel An area in the GNOME Desktop where you have 
access to certain actions and information such as 
launching applications, date and time, system 
sound, volume and more. 

Securing the system Shutting down, logging off or locking the system 
so that other users cannot access your information. 

File system A specification for storing and organising files on 
storage devices such as hard disks. 

File extension The part of the file name that follows the final 
period. File type can be recognised by the 
extension on the file name. 

File compression File compression is a way that a number of files 
can be compressed into a single file or a single file 
can be compressed to take up less space on a hard 
drive or other medium. 

Study Tips 

You may find it useful to skim through an entire block of content first, 
paying special attention to the headings and introductions, and then go 
through a second time for more in-depth study and practice. 

However, we recommend that you do the activities as they appear (where 
you see the icon). They are essential study materials, offering 
practice in particular skills that will build your proficiency in word 
processing. 

This module forms the basis for subsequent modules in this course. Keep 
linking the new content that you are studying with content in this module 
that you have already covered and with your own general knowledge, to 
deepen your understanding of the operations you are learning. 
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If you have difficulty understanding any area, try working at it slowly. If 
you still do not understand, seek help. 

 

Pre-knowledge 

Before beginning this module, we recommend that you: 

• Study Module 1, because it provides essential background for 
this module. 

• Be comfortable using a keyboard to input text and a mouse to 
click on objects. 

 

The Ubuntu Operating System 
Section overview 
Welcome to this section on the Ubuntu Operating System. After studying 
this section you will: 

• be able to start up and shut down your computer safely 
• be able to login and logout of your Ubuntu operating system 
• become familiar with the features of the GNOME graphical user 

interface 
• be able to customise the GNOME desktop 
• secure your system so that the information on your system is safe 

from others 
• use the GNOME help files to get help 
• install and remove applications in Ubuntu 

 
Introduction 

In Module 1, you learned that the operating system is a set of software 
that enables the computer to function by controlling hardware devices, 
allowing network capability and allowing software applications to work 
with hardware. In this section you will be introduced to one brand of 
operating system, Ubuntu Linux version 9 – also know as Jaunty 
Jackalope. 

Ubuntu Linux can come in variations with three graphical user interface 
(GUI) environments: GNOME (Ubuntu), KDE (Kubuntu) or Xfce 
(Xubuntu). For this module, we will concern ourselves with the GNOME 
GUI. 
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First Steps with the Computer 
Starting the computer 

Most computers have an On/Off switch on the front. Press the On/Off 
switch on the front of the computer. This will initiate the boot process. 
During this process the start-up routines that are stored in the ROM of the 
computer will take control of the computer. 

One of the things these routines do is to read certain areas of the hard 
drive to search for the operating system. The start-up routines will then 
load the operating system into the RAM of the computer and pass over 
control to it. 

Depending on how the computer has been configured, one of three things 
will happen: 

• The operating system will automatically load the GUI (Graphical 
user interface) and start this for a default user. The system will be 
available for immediate use. 

• The operating system will automatically load the GUI, but you 
will be prompted to enter a username and password. These will 
be given to you by whoever installed the system. 

• Only the text based operating system will load. In this case you 
will need to logon and then start the GUI. In this case you will 
see a black screen on which the prompt Logon: appears. 

Logon to Ubuntu 

After Ubuntu has gone through its boot procedures, either the GUI will 
load or you will be prompted to input your username and password. If 
you need to use username and password to access your system, remember 
that passwords are case sensitive. If you are given a password, you must 
enter it exactly as given. 
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When you have successfully entered your username and password, 
the GNOME desktop will load. 

 
The GNOME Graphical User Interface 
GNOME provides you with a graphical view that makes it easier to 
perform tasks either using the keyboard or with the click of a mouse. 

The image below illustrates the main features of the GNOME graphical 
user interface. 
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Windows 
A window is a rectangular area of the screen that displays an application 
running on your system. Windows usually have a border all around and a 
title bar at the top. 

You can think of a window as a screen within the screen or as pieces of 
paper on your desktop. You can have many windows open at once, 
allowing you to have more than one application visible and work on more 
than one task at a time. 

Windows can overlap or be side by side. You can control a window’s 
position of the screen, as well as its size. You can control which windows 
overlap other windows, so the one you want to work with is completely 
visible. 

Below is an example of a window containing the Ubuntu Help Center 
application. 

 
 

Working with Windows 

Move the window 

Drag the title bar to move the window. You can click on any part of the 
title bar except the buttons at either end to begin the drag action. The 
window will move on the screen as you drag the mouse. 

Resize the window 

Drag one of the borders to expand or contract the window on that side. 
Drag a corner to change two sides at once. The resize pointer appears 
when your mouse is in the correct position to begin the drag action. 

Minimise the window 

Click on the Minimise button in the title bar, the leftmost of the group of 
three on the right. This removes the window from view. 
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Maximise the window 

Click on the Maximise button in the title bar, the middle of the group of 
three on the right. This expands the window so it fills the screen (the 
panels remain visible). 

Unmaximise the window 

When a window is maximised, click again on the Maximise button to 
restore it to its previous position and size on the screen. 

Close the window 

Click the Close button, the rightmost of the group of three on the right. 
Closing the window may also close the application itself. 

Scrolling 

If the application that is open is too large for the window, you will see 
scroll bars either on the right, bottom or both. Drag the scroll bar or click 
on the arrows at either end of the scrollbar to scroll through the windows 
contents. 

 
Panels 
A panel is an area in the GNOME Desktop where you have access to 
certain actions and information.  For example, you can launch 
applications, see the date and time, control the system sound volume and 
more. 

By default, the GNOME Desktop contains a panel at the top edge of the 
screen and a panel at the bottom edge of the screen. You can customise 
panels to your liking. You can change their behaviour and appearance 
and you can add or remove objects from your panels. You can create 
multiple panels and choose different properties, objects and backgrounds 
for each panel. You can also hide panels. 

 
 

Working with Panels 

Move a panel 

Drag a panel to another side of the screen to move it there. Click on any 
vacant space on the panel to begin the drag. 
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Panel properties 

Right-click on a vacant space on a panel, then choose Properties from 
the context menu. You can set the following panel properties: 

• Orientation: Select the position of the panel on your screen. 
Click on the required position for the panel. 

• Size: Use the spin box to specify the size of the panel. 

• Expand: By default, a panel expands to the full length of the 
edge of the screen where it is located. A panel that does not 
expand can be moved away from the screen edges to any part of 
the screen. 

• Autohide: Select this option if you want the panel to only be 
fully visible when the mouse pointer is over it. The panel hides 
off-screen along its longest edge, leaving a narrow part visible 
along the edge of the desktop. Move the mouse pointer over the 
visible part of the panel to make it move back into view. 

• Show hide buttons: Select this option to display hide buttons at 
each end of your panel. Clicking on a hide button moves the 
panel lengthways, hiding it off-screen except for the hide button 
at the opposite end. Click this hide button to restore the panel to 
being fully visible. 

• Arrows on hide buttons: Select this option to display arrows on 
the hide buttons, if the hide button is enabled. 

• Background: Click on the Background tab to set the background 
colour or image for the panel. 

 

Adding and Deleting Panels 
To add a panel, right-click on a vacant space on any panel, then choose 
New Panel. The new panel is added to the GNOME Desktop. The new 
panel contains no objects, but you can customise it to suit your 
preferences. 

To delete a panel right-click on the panel that you want to delete, then 
choose Delete This Panel. 

Note: You must always have at least one panel in the GNOME Desktop. 
If you have only one panel in the GNOME Desktop, you cannot delete 
that panel. 

Users Guide 
For a detailed GNOME User’s Guide, you can go to the GNOME site 
at http://library.gnome.org/users/user-guide/stable/index.html.en. 

 

http://library.gnome.org/users/user-guide/stable/index.html.en�
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Securing your system 
Locking, Logging Off and Restarting the Computer 

When you are finished your Ubuntu session, it’s a good practice to either 
lock, log off or shutdown your computer. The main reason for this has to 
do with security – if your computer is left unattended with you logged in, 
others could then use the computer and impersonate you. 

• Click on the icon on the top-right part of your desktop. This will 
open a dialogue window with options for locking, logging off, 
restarting or shutting down your computer. 

 
 

• Click on the option you want. The options are: 
• Guest session: this option effectively locks the screen 

for the current user, but creates a “guest” session so that 
someone else can use the computer, but without access to 
your settings or files. 

• Lock screen: this option locks the screen so that nobody 
can use the computer until you unlock the screen with 
your password. 

• Log out: this logs you out of the system. For someone to 
use the computer, they must first log in. 

• Hibernate: this option puts the computer in a “sleep” 
mode. 

• Restart: shuts down the computer and then restarts it. 
• Shut Down: shuts down the computer and turns the 

power off. 
 

Tip: Never just shutdown the computer by pressing the On/Off switch. 
This can do damage to your operating system or hardware and could 
result in the loss of data. Always shut down from the Ubuntu menu. 
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Shut down a non-responding application 
It may happen that an application freezes and will not respond to mouse 
clicks or keyboard commands. You can close the application without 
restarting your system by using System Monitor. 

1. From the Ubuntu System menu, click on Administration, then 
on System Monitor. 

 
2. When System Monitor loads, click on the Processes tab to view 

all of the processes running on the system. 

 
3. Click on the non-responding process and then click the End 

Process button to shut down the application. 
4. When done, quit System Monitor by clicking on the Close icon in 

the top right of the screen. 

What to do if the entire system freezes 
If the entire system freezes, do not immediately switch of the system with 
the power switch. This could cause serious damage to the entire system. 
This is only a final resort. 
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The most likely cause of a frozen system lies with the GUI. 

1. Wait a while. The system may wake up on its own. 
2. If the system doesn’t respond after a few minutes, press these 

keys on your keyboard at the same time: Ctrl + Alt + 
Backspace. 

This will cause you to lose all unsaved work, but it will preserve the 
system itself. 

 

Getting Help 
The help systems in Ubuntu are searchable databases of information 
about the operating system and applications you will be using. Along 
with help information on the Internet, they are a very good starting point 
for when you have questions or problems with your system. 

The Ubuntu Help Center 
To access the Ubuntu Help Center, click on the Help icon on the top of 
your screen. 

 
You can either browse the help files by clicking on the links in the Help 
window or you can search for help on a specific topic. 

Context Help 
You can access help files on any application you are using by clicking on 
the Help menu from within the application. For example, if you want to 
get help with using the System Monitor, click on Help from within 
System Monitor and the click on Contents. 
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Using Help as a Tutorial 
Become as familiar as possible with the help system. These notes will 
provide you with an introduction to Linux using the GNOME desktop. 
When you have worked through a section in these notes, you could read 
what the GNOME help system has to say on the topic. If you wish to 
become an expert, you will need to read further and discover the full 
power of Linux. The help system is the best place to start. 

 

Basic Information and Operations 
The System Monitor 
The System Monitor displays basic system information and monitors 
system processes and resources. As you have already seen in the previous 
section, you can also use System Monitor to change how your system 
behaves, such as closing non-responding programs. 
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To start System Monitor: 

1. From the Ubuntu System menu, click on Administration, then 
on System Monitor. 

 
To close System Monitor: 

1. Click on the Close icon  in the top right corner of the 
application. 

 
Viewing System Information 
The System tab in System Monitor will show you the following 
information about your system: 

• distribution version (the version of the operating system you have 
installed) 

• hardware: RAM, processor type and processor speed 
• system status: available disk space 

 

Viewing Active Processes 
You have seen in the previous section that you can click on the Processes 
tab in System Monitor to view and, if needed, stop processes that are 
running on your system. 

 

Viewing Resource Use 
Clicking on the Resources tab shows you a display of your system’s CPU 
usage, memory usage and network activity as it is being monitored. 

 

View the File Systems 
The File Systems tab shows you what file systems are in use and how 
much disk space is being used and how much is available. 
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Desktop Configuration 
In this section you will learn how to adjust your operating system settings 
to customise your GNOME desktop. You can access most system 
preference settings from the System menu by clicking on System and 
then Preferences: 

 
or by clicking on System and then Administration: 

 
Other settings can be accessed directly from the system window. 
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Set the Date and Time 
1. From the System-Administration menu, click on Time and 

Date. 

 
2. Click on Unlock to unlock the settings window and enter your 

system password when prompted. 
3. Adjust the time zone, date and time on the calendar and clock. 

 
 

4. Click Close when done. 
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Set the volume level 
1. To access your sound settings, click on the Volume icon at the 

top of your system workspace. 

 
2. Slide the volume control slider to the left or right to set the 

volume on your system. 
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Change the desktop appearance 
3. From the System menu click on Preferences and select 

Appearance. 

 
 

4. Click on the Theme tab to set a desktop theme. A theme is a 
group of coordinated settings that specify the visual appearance 
of the desktop. 

5. Click on the Background tab to set the desktop background. You 
can either set a background colour or use a picture for the 
background. 

6. Click on the Fonts tab to specify the fonts that are used in the 
desktop. 

7. Click on the Interface tab to customise the appearance of menus, 
menu bars and tool bars. 

8. Click on the visual effects tab to enable or disable a group of 
visual effects intended to make your desktop easier to use. 

 

Change screensaver 
A screensaver is a visual effect that occurs on your screen when your 
computer has been idle for a certain amount of time. Screensavers were 
designed to be visually interesting and to provide some motion on the 
screen since some older computer monitors are susceptible to damage if 
the same image is left on the screen for a long period of time. 
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1. To access screensaver settings, from the System-Preferences 
menu click on Screensaver. 

 
 

2. Choose a screensaver theme from the list on the left of the 
window. 

3. Set the length of time for the computer to be idle before the 
screensaver is activated. 

4. Make sure the box is checked beside Activate screensaver when 
computer is idle. Uncheck this box to disable the screensaver. 

5. If you like, you can have the screensaver lock the screen when it 
activates. This means that for someone to use the computer they 
will have to input their password. 

 

Set screen pixel resolution 
Note: This setting is not standard for all computers; it depends on the 
display card being used. You should refer to your video card 
documentation to set the screen resolution. 

 

Set keyboard language 
The keyboard language defines the position of the various keys on the 
keyboard. For example, British, American and French keyboards all have 
different layouts. If some of the keys generate a different letter to that 
shown on the key itself, it could be that the keyboard language setting 
needs to be changed. 

1. Click on System>Preferences>Keyboard 
2. When the Keyboard dialogue window opens, click on the 

Layouts tab. 
3. Click on the Add button to add a keyboard layout. 
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4. Click on the By language tab to choose your new keyboard 

layout by language. 
5. Choose a new keyboard layout from the Language list and 

Variants list and then click the Add button. 

 
 

6. Click on the Default radio button to make this your default 
keyboard layout and then click Close. 
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Formatting Discs 
Formatting a disk, device or partition means to prepare that device for 
storing data. When you format a device, you apply a specific data-storage 
format to that device. It’s important to keep in mind that the format you 
apply may not be read or written to by all operating systems. For 
example, you can’t format a hard disk for a Macintosh system and have 
the disk read by a Microsoft Windows system. 

 
File systems 
A file system is a specification for storing and organising files on storage 
devices such as hard disks. A file system is absolutely necessary for your 
operating system to be able to store and access files. Common file 
systems are: 

• ext2 and ext3: These are Linux files systems. Ubuntu uses ext3 
as its default file system. 

• FAT16 and FAT32: These are older Windows file systems. If 
you need to format a disk that is going to be used on a number of 
different operating systems, FAT32 is a good choice because it 
can be read and written to by Linux, Macintosh OSX and newer 
versions of Microsoft Windows. 

• NTFS: This is the file system for newer versions of Microsoft 
Windows. 

• HFS+: This is the Macintosh OSX default file system. 
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You can access disks on your system from the GNOME menu by clicking 
on System>Administration>Partition Editor. 

 

 
 

Installing and Uninstalling Applications 
Install applications from distribution CDs 
Ubuntu Linux maintains a database of applications and their locations. 
Initially these are applications that are stored on the distribution CDs. 
Depending on the particular installation, only certain of these may be 
installed on a given system. The following illustrates how to install 
OpenOffice from the Ubuntu distribution CDs. 

1. System>Administration>Synaptic Package Manager. 
2. Enter the root password when prompted. 
3. Click All. 
4. Click on OpenOffice to expand its contents. 
5. Click on Mark for installation. A window appears warning you of 

dependencies. A dependency refers to other software which 
needs to be installed on the machine before the application can be 
installed. 
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6. Click Apply. 
7. When prompted, insert the required CD and click OK. 
8. Other prompts may appear. Respond by clicking OK if you wish 

to proceed with the installation. 
9. Verify that the application has been installed. 

Open Office can also be downloaded from http://www.openoffice.org 

 

Install applications from a CD with an install program 
You may get an application as part of a CD or through a download across 
the Internet. In some cases these applications are distributed with an 
install file. Double clicking on this in a file manager will initiate an 
automated installation process. You then simply sit back and wait for the 
entire process to complete. 

 

Install an application using the File Manager 
The following illustration assumes the application is located on a CD. 

1. Double click on the CD-ROM icon on the desktop. 
2. Locate the directory in which the application installation file is 

located.(This process will be explained fully in the next section 
on file management) 

3. Double click on the application. 

 

Uninstall an application 
The following example illustrates how to uninstall an application 

1. Start Applications>System>Synaptic Package Manager. 
2. Enter the root password when prompted. 
3. Select the software you want to remove. 

http://www.openoffice.org/�
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4. Select Mark for Removal. 
5. Click Apply. 

 

Summary 

In this section, you learned: 

• How to start up and shut down your computer safely and how to 
login and logout of the Ubuntu operating system. 

• About the main features of the GNOME graphical user interface. 
• How to customise GNOME to suit your personal preferences. 
• How to secure your system so that your information is safe from 

other users. 
• How to install and remove applications in Ubuntu. 
• How to access help files in Ubuntu. 
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File Management 
Section overview 
Welcome to this section on File Management. After studying this section 
you will: 

• understand the concept of directories and files as they apply to 
the Linux operating system 

• be able to use the Nautilus File Browser to navigate through 
directories 

• be able to change the view options for directories 
• create, rename, move, copy and delete directories 
• change permissions for directories 
• understand how files are named and what filename extensions are 
• be able to sort files by name, size and date modified 
• create, rename, move, copy and delete files 
• understand the importance of backing up data 
• restore files from the trash bin 
• empty the trash bin 
• search for files and directories 
• use a file compression utility 

 

Concepts 

To understand the concept of a directory, consider an analogy of an office 
block containing a number of offices. Each office has a name. Inside each 
office there are a number of filing cabinets, each of which is named. Files 
are stored in the filing cabinets. Each file also has a name. 

Suppose a file called Lombard is located in the Staff cabinet of the 
Administration office. This could be described in a shorthand form as: 

/Administration/Staff/Lombard 

In the same way /Stores/Suppliers/Kumar would indicate a file called 
Kumar in the Suppliers filing cabinet in the Stores office. 

Directories on a computer system are similar to the offices and filing 
cabinets. A directory is a container that can contain files or other 
directories. A directory located inside another directory is called a sub-
directory. Sometimes the word folder is used in place of the word 
directory. One difference between the analogy and a computer system is 
that in the former case we are dealing with physical objects whereas in 
the latter we are dealing with a more abstract structure. 

Directories, sub-directories and files are arranged in a hierarchical 
structure called a tree. A typical computer will contain many thousands of 
files stored in many directories. Each directory contains files that are 
related in some way. The starting point of the tree is called the root. Do 
not confuse this usage of the word with the special user that has complete 
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control over the system. Root is designated by the / symbol. This symbol 
is also used to separate the different levels of the hierarchy. 

A directory structure may contain many levels of sub-directories. The 
following diagram illustrates part of a Linux system directory structure. 

 

The full description of the location of a file is called is path. If we wish to 
describe a file fully, we need to include its path. An example from the 
previous diagram would be: /home/david/Letters/Tax(2004-04-04). 

Linux names are case sensitive. Hence the three names tax, Tax and 
TAX are all different as far as Linux is concerned. Using the wrong case 
for letters is a common source of errors. 

If you have worked with Windows, the Linux directory structure may 
seem confusing at first. Each system has a single directory system. Drives 
are located within branches of the structure rather than the structure 
starting with a drive. Linux goes much further and includes devices such 
as ports and printers within the directory structure. This follows from the 
fact that Linux treats files and devices in the same way. 

The process of adding components to the Linux directory hierarchy is 
called mounting and removing them is called unmounting. 

The home directory is of special importance in Linux. When a new user 
is added to the system, Linux creates a sub-directory of the same name in 
home. For example, if the user dorothy is added, Linux will create the 
directory /home/dorothy at the same time. This sub-directory is known as 
the user’s home directory. Each user will create a further series of sub-
directories in which he/she will store files. 

Each user’s home directory is private to that user. Apart from the owner 
of the home directory, the only other user that normally has access to it is 
the root user. 
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Each user can access his/her home directory by clicking on the System 
Menu then Home. 

 
Storage Devices 

You already know that the devices used by an operating system to store 
files and folders are the hard disk, diskette, CD-ROM, network drives. 

For long term storage, files are stored on various secondary memory 
devices. These include hard disks, floppy disks, CD-ROMs, DVDs, Zip 
disks, tape and flash memory. These devices were described in Module 1. 

Although we can think of directories as containers for files and sub-
directories, these are logical structures rather than physical areas on a 
disk. The actual method of physically storing files on disk and organising 
them in directories is a very technical topic. From a user’s perspective, 
the important thing is to understand directories as providing a logical 
method of grouping related files together in one place. 

Where computers are connected together through a network, each user 
will see the disk drives on other computers as part of his/her own 
directory tree. In fact, if the user has not set up the system, he/she will not 
necessarily even be aware of the physical location of different parts of the 
directory tree. 

One of the strengths of Linux is that it fully integrates a network into a 
single system. 

 

Directories/Folders 
Nautilus File Browser 

Ubuntu has a built-in application called Nautilus for navigating through 
the file system on your computer and for managing your computer’s 
desktop. Nautilus is always running while you are using GNOME. To 
open a new Nautilus window, choose an item from Places menu on the 
top panel. 

 

The Home Folder 

Whenever a new user is created in Ubuntu, a folder, called the Home 
Folder, is also created for that user. You can access your Home Folder by 
clicking on the Places menu and choosing Home Folder. 
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The Home Folder contains a number of default folders to hold documents 
for each user. These folders are: 

• Desktop: this folder contains all of the objects that will appear on 
your desktop, such as files, folders and shortcuts to places or 
applications. 

• Documents: A folder to store documents such as word processor 
files, spreadsheets or databases. 

• Music: a folder to store your music files. 
• Pictures: a folder to hold graphics and photographs. 
• Public: a folder that you can use to share files with other users. 
• Templates: used to store documents that will be used as a 

template to create new documents in OpenOffice or other 
applications. 

• Videos: a folder used to store video files. 

 
Alternate views 
You can change how Nautilus displays directories and files by changing 
the view from the folder menu. You can choose to view the folder 
contents as icons, as a list or in “Compact View” which has small icons 
with the file names. 
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Icon View 

 
Compact View 
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List View 

 

Note: Viewing directories in List View also displays the size of the file 
or the number of files or sub-directories within a directory, the type of 
file and the date the file or folder was last modified. 

 

Navigating through directories 

There are many ways to navigate through folders. As you use Ubuntu, 
you will find the navigation style that suits you best. 

 

The Back and Forward icons allow you to trace your steps 
back and forward through the directories you have visited 
during your current session. 

 
To navigate up one level in the directory structure, click on 
the Up button. 

 

To return to the home directory at any stage, press the Home 
icon. 

 
To view all of the storage devices on your computer, click on 
the Computer icon. 

 

To search for a file or directory, click on the Search button 
and type the file name or directory name in the search bar. 
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You can also move to a new directory, by double clicking on a directory 
icon in the main pane or choosing a directory from the list of Places in the 
left pane. 

Finally, you can also type the name of the directory into the location 
window if you know its path. Recall that Linux file and directory names 
are case sensitive. 

 

Creating and deleting directories 

The following example illustrates how to create directories and sub-
directories in your home directory. 

1. Click the Home icon. 
2. From the File menu, click on Create Folder. 
3. Enter the name for the new directory (in this case, it is named 

Recipes). 

 

You could, if you wish, create sub-directories and create another level of 
sub-directories within each. First work out a meaningful directory 
structure for your own needs, and then create this structure using the 
method that has just been described. 

To delete a directory, click on the directory name or icon and press the 
Delete key on your keyboard. 
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Renaming directories 

Extension Example Description 

sxw jamaica.sxw A Writer text file 

sxc populationSA.sxc A Calc spreadsheet file 

stw invoice.stw A template file that can be used as the basis for 
creating Writer text files 

sxi client.sxi An Impress presentation 

pdf contract.pdf A picture document format file. This format 
allows a file to be sent in a format that can only 
be read and not edited. To read such a file you 
would need a pdf reader 

htm, html index.htm Htm and html files are files that can be read 
using a web browser 

txt notes.txt A text file containing pure text without any 
formatting 

rtf plans.rtf A rich text format file. This is a format that can 
be used for exchanging files between different 
types of system 

doc, docx jamaica.doc A Microsoft Word document file 

xls, xlsx populationSA.xls A Microsoft Excel spreadsheet file 

ppt, pptx client.ppt A Microsoft PowerPoint file 

pps, ppsx client.pps A Microsoft PowerPoint presentation file 

mdb vendors.mdb A Microsoft Access database file 

zip install.zip A compressed file in zip format 

gz install.gz A compressed file in gzip format 

tar oo-137.i586.tar A tarball file  .tar files are used for creating 
installation packages 

png sky.png A common format for storing graphic images 

jpg, jpeg sky.jpg A common format for storing graphic images 

tif sky.tif A common format for storing graphic images 

gif sky.gif A common format for storing graphic images 
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You can rename a directory by clicking on the icon or name of the 
directory and clicking on Edit->Rename. Then simply type the new 
name in the name field. 

 

Copying, Pasting and Moving Directories 

To move a directory to another place: 

1. Click on the directory name or icon and hold down the left mouse 
button while you drag it to the new location. 

or 

1. Click on the directory name or icon, then choose Edit>Cut from 
the menu. 

2. Go to the location you want to place the directory and the click 
on Edit->Paste from the menu. 

To copy a directory: 

1. Click on the directory name or icon, then choose Edit>Copy 
from the menu. 

2. Go to the location you want to place the directory and the click 
on Edit->Paste from the menu. 

 

Working with Files 

Files can be recognised by the extension on the file name. This is the part 
of the file name that follows the final period. The following table 
illustrates some common file names and examples of each. 

File extensions are a Microsoft concept and are not actually needed in 
Linux. They are however useful in providing information for users about 
the contents or format of files. 

 

Extension Example Description 

wav trumpet.wav An audio file 

au trumpet.au An audio file 

mpg concert.mpg A video file 

avi concert.avi A video file 

tmp ws0001.tmp A temporary file 
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Change folder and file permissions 

By default, other users can’t access the files in your home directory. As 
the owner of these directories and files, you can change the permissions 
so that other users can access them. 

You can set permissions for three categories of users: 

• owner: The user that created the file or folder 

• group: A group of users to which the owner belongs 

• others: All other users not already included 

For each category of user, different permissions can be set. These behave 
differently for files and folders, as follows: 

• read: Files can be opened, Directory contents can be displayed 

• write: Files can be edited or deleted, Directory contents can be 
modified 

• execute: Executable files can be run as a program, Directories 
can be entered 

 

Change permissions on a directory 
In this example, you will change the permission on the Public directory of 
your Home folder to allow other users to access these files. 

1. Open your Home folder (click on Places>Home Folder) 

2. Click on the Public directory and choose File>Properties 

3. Click on the Permissions tab 
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4. Change the permissions for Owner, Group and Others to Create 
and delete files. 

5. Click the Share tab. 

 

6. Check the boxes Share this folder and allow other people to 
write in this folder. 

 
Change permissions on a file 

By default, Linux locks access to files so that they cannot be changed by 
anyone other than the owner or members of the group. 

1. Open Nautilus and locate the file whose permissions you wish to 
view or change. 

2. Click on the file and select File>Properties from the menu. 

3. Click the Permissions tab. The current permissions will be 
checked. 
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4. Change the permissions as desired. 

 

Sort files by name, size, type, date modified 

Files can be sorted by name, type, size and date by clicking on the titles at 
the top of the pane. 

1. Open the Nautilus file browser and access the directory you wish 
to sort. 

2. Switch to List view. 

 
3. Click on Name. This will sort the files in ascending alphabetic 

order by name. 

4. Click on Name a second time. This will now sort the files in 
descending order of name. 
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When you sort files, the directories will appear ahead of the files. 
Directories and files will be sorted separately. 

1. Click Date Modified: This will sort the files in date order 
starting with the most recent. 

2. Click Date Modified a second time: This will now sort them 
with the oldest appearing first. 

3. Click Size: This will sort the files in order of size with the largest 
at the top. 

4. Click Size a second time: This will sort them in the reverse order 
of size. 

5. Click Type: This will sort the files alphabetically by type. 

6. Click Type a second time: This will sort them by type in the 
reverse order. 

 

Copying, Pasting, Moving and Deleting Files 
 

To move a file to another place: 

1. Click on the file name or icon and hold down the left mouse 
button while you drag it to the new location. 

or 

1. Click on the file name or icon, then choose Edit>Cut from the 
menu. 

2. Go to the location you want to place the file and the click on 
Edit>Paste from the menu. 

To copy a file: 

1. Click on the file name or icon, then choose Edit>Copy from the 
menu. 

2. Go to the location you want to place the file and the click on 
Edit->Paste from the menu. 

 

Renaming Files 

You can rename a file by clicking on the icon or name of the file and 
clicking on Edit>Rename. Then simply type the new name in the name 
field. 

Note: The part of a file name following the final period (full stop) is 
called the file extension. This often has a special significance which will 
be lost if it is changed. For example, the system will recognise that a file 
having a pdf extension can be opened with a pdf reader or that a file with 
a png extension is a graphic image. 

If you do change a file name, only change the part that is to the left of the 
first period. 
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Importance of Backups 

There are many things that can cause loss of files. These include: 

1. Mechanical failure of a hard drive. 

2. Damage to the system due to natural disasters such as fire, floods 
and earth movement. 

3. Theft of the system. 

4. Corruption of data due to computer viruses. 

5. Deliberate corruption or deletion of data through criminal 
activity. 

In order to protect data, it is important that copies of important files are 
made and kept in a separate location so that if loss occurs to the main 
system, data can be recovered from the copies. Copies of important files 
are referred to as backups. 

 

Deleting and Restoring Files 

When you delete files or directories in Ubuntu, by default the files are 
moved to the trash bin where they wait until the trash is emptied. This 
means that if you delete files by mistake, you can restore them from the 
trash bin. However, once you empty the trash those files can no longer be 
easily restored, so be careful when you are deleting items. 

 

Delete files, directories/folders to the trash bin 
1. Select (highlight) the files you wish to delete. 

2. Do any one of the following: 

•  press the Delete key 
•  drag the file to the trash bin 
•  choose Edit>Move to Trash from the menu. 

 

Restore files, directories/folders from the recycle bin/wastebasket/trash 
1. Double click on the Trash icon on the desktop OR open your home 

folder by choosing Places>Home Folder. From there navigate to 
Trash. 

2. Select the files you wish to restore. 

3. Choose Edit>Restore. The files are then restored to the folder 
from which they were deleted. 
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Empty the recycle bin 

With time Trash will accumulate hundreds of files. Rather than waste 
space, empty Trash on a regular basis. 

1. Double click on the Trash icon on the desktop OR open your home 
folder by choosing Places>Home Folder. From there navigate to 
Trash. 

2. Choose File> Empty Trash from the menu. 

 

Searching for files and folders 

The first step to keeping track of your files and directories is to create a 
logical set of directories that works for you. When you are having trouble 
locating a file or directory, however, Ubuntu has a search utility that can 
help. 

 

Find Files 

1. Choose Places>Search for Files from the desktop menu. 

 
2. In the Name contains field, type in the name of the file. 

3. Choose a directory to search in from the Look in folder field. 
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4. Click on the Find button. Your search results will appear in a 
new window. If your file is in the results, you can double-click 
on it to open. 

 

 

Note: In searching for files, the wildcard character, *, plays a very useful 
role. * represents any number of characters. 

For example: 

 doc* means any file with a name beginning with the letters doc 

 *doc means any file with a name ending with the letters doc 

 *doc* means any file containing the letters doc in its name 
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Search for files by content, date modified, date created, size, wildcards 

You can narrow your search by specifying other search options such as 
when the file was modified, who the owner of the file is, what the file 
size is and what text is contained in the file. You can also use a 
combination of the other options. 

Expand the Select more options field and choose the options you want 
from the drop-down menu. You will then be prompted for information 
regarding the option you chose. 

 

 

Compressing Files 

Each file has a size associated with it. Roughly speaking the amount of 
space a file occupies of disk is about the same as its file size (in reality, it 
takes up somewhat more space than this). When files are stored on a CD 
or transmitted across the Internet, it is important to know the amount of 
disk space they occupy. Special algorithms (methods) have been 
developed to compress files into smaller sizes. 

File compression is a way that a number of files can be compressed into a 
single file or a single file can be compressed to take up less space on a 
hard drive or other medium. For a compressed file to be usable, it must 
first be decompressed. 
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There are numerous utilities that enable you to work with compressed 
files. The next example will illustrate the use of Archive Manager, an 
open source compression utility for Ubuntu. 
 

Compressed archive formats 

The following formats are installed by default with Ubuntu. There are 
other types of archives in use, but they require additional software to be 
installed on your system. 

Format File extension Note 

tar .tar  

gzip .tar.gz, .tgz, .gz Compressed .tar or compressed single file 

bzip .tar.bz, .tbz, .bz Compressed .tar or compressed single file 

bzip2 .tar.bz2, .tbz2, .bz2 Compressed .tar or compressed single file 

lzma .tar.lzma, .lzma Compressed .tar or compressed single file 

zip .zip Common format used in Microsoft Windows 
systems 

jar .jar, .ear, .war  

CD 
images 

.iso Read-only 
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Compress files in a folder on a drive 
1. Using Nautilus, open the directory with the files you want to 

compress. 

2. Select (highlight) the files which you want to compress. 

3. Choose Edit>Create Archive to open the Archive Manager 
utility. 

 

4. In Archive Manager, type in a name for the archive and then 
choose the type of archive you want to create. 
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5. Click on the Create button. The compressed file will be saved in 
the same folder. 

 
 
Extract compressed files from a location on a drive 

1. Using Nautilus, open the directory with the compressed archive 
you want to extract.  

2. Select (highlight) the archive which you want to extract. 

 
  



44 
 
 

 

 

3. Choose Edit>Extract Here to open the Archive Manager utility. 

 

4. The archive will be extracted to the same folder, creating a 
subdirectory with the archive name. This subdirectory will 
contain the extracted files. 
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Summary 

In this section, you learned: 

• the concept of directories and files as they apply to the Linux 
operating system 

• how to use the Nautilus File Browser to: 
o navigate through directories 
o change the view options for directories 
o create, rename, move, copy and delete directories 
o change permissions for directories 

• how files are named and what filename extensions are 
• how to use the Nautilus File Browser to: 

o sort files by name, size and date modified 
o create, rename, move, copy and delete files 

• the importance of backing up data 
• How to use the Trash Bin  
• How to search for files and directories 
• How to use a file compression utility 
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Ubuntu Utilities 
Section overview 

Utilities are programs that are included with the operating system. They 
are installed with the operating system, but are in fact application 
software. They can be very helpful, as they perform important tasks but 
tend to use very little of your system’s resources. 

You have already been introduced to the file compression utility, Archive 
Manager, in the previous section. In this section, you will use utilities for 
capturing images of your computer screen and for editing text files. 

After studying this section you will be able to: 

• Use the Print Screen utility to take screenshots or images of 
your computer screen. 

• Use the Text Editor utility as a simple word processing 
application for editing text files. 

 
Print Screen 
Print screen takes a snapshot of your desktop and saves it as an image, 
which you can then use in documents. 

1. Press the Print Screen button on the keyboard (it may be 
abbreviated to Prt Scr or similar). This activates an application 
which captures an image of your screen. 

2. Choose whether to capture the whole screen, the active window 
or a portion of the screen. 

3. If you would like a few seconds to get the screen ready before 
capture, set the delay time. 
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4. Click the Take Screenshot button. 
5. Specify a name and location in which to save the snapshot and 

click on the Save button. 

 
The snapshot will be saved in .png format, which can be opened with 
most standard graphics programs. 

The image can then be inserted into a document, edited with a graphics 
program or sent by email. 

 

Text Editing 

Text editing is an application that allows you to create text documents. It 
is a simple word processor application and although it doesn’t have the 
features of an advanced word processing program like OpenOffice 
Writer, it can be very helpful. 
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Start Text Editor 
1. Click on Applications from the desktop menu 
2. Go to Accessories 
3. Click on Text Editor 

 
The components of the screen are shown below. 

 
 

Close Text Editor 
1. Choose File>Quit from the text editor menu. 

This will close all open documents and exit Text Editor. If you have 
made any modifications to open documents, Text Editor will remind you 
that the document has not been saved and ask you whether you wish to 
save or keep it. It will also give you the option of cancelling the Quit 
operation. 
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Open a file 
One of the advantages that text editors provide for us is the facility to 
save our work and recall it at a later time. We can then print our work or 
make further changes (edit). In addition, we are able to create many 
versions of the same document, each of which can be saved on our hard 
drive under an appropriate name. 

To open a document: 

1. Choose File>Open from the Text Editor menu 

OR 

Click on the Open button in the Text Editor tool bar. 

The Open dialogue will appear. In general, this will point to your home 
directory. 

 
 

1. If necessary, navigate to the desired directory. 
2. Highlight the file you wish to open. 
3. Click Open. 
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Create a new document 
A new document is created for you each time you open Text Editor. 

To create a new document from within Text Editor: 

1. Choose File>New from the Text Editor menu. This will display a 
blank screen in which you can create a document. 

2. Using your keyboard, type the text for the document. Use the 
<Enter> or <Return> key on your keyboard to start a new 
paragraph. 

 

Save your document 
When you work with a document on your computer, the working form 
resides in the computer's RAM. Remember from Module 1, this is 
temporary memory used for your current activities. Since RAM is 
volatile, when the computer is switched off, everything that is in RAM is 
automatically lost. In order to keep your work you will need to save your 
documents before you shut off your computer. 

When you save a document, you give it a name and you specify where it 
is to be stored. 

If you have opened a document and made some changes, the process of 
saving it is very simple: 

1. Choose File>Save from the Text Editor menu. 

This will change the contents of the stored version so that it is identical to 
the version that is displayed on your screen. In this case, the previous 
version on disk is overwritten. If you use File>Save in a newly created 
document, Text Editor will automatically assume that you wish to use 
File/Save as. 

 

Saving a new document 
When you create a document from scratch, there is no version stored on 
disk. To save the file to disk: 

1. Choose File>Save as from the Text Editor menu. 

The Save as dialogue will appear. In general, this will point to your 
home directory. 
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2. If necessary, navigate to the directory in which you wish to save 

the file. 
3. Enter a name into the Name window. 
4. Click Save. 

 

Summary 

In this section, you learned: 

• How to use the Print Screen utility to take screenshots or 
images of your computer screen. 

• How to use the Text Editor utility as a simple word processing 
application for editing text files. 
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Print Management 
Section overview 

Remember from Module 1, you should avoid printing documents unless it 
is necessary because of the impact on the environment and since it is 
quite possible to do much of your reading on-screen. 

However, you may want to print documents to read when you can’t be 
near a computer, for handouts for meetings or presentations or even your 
photographs. 

After studying this section you will be able to: 

• Set up a printer in Ubuntu. 

• Print documents from an application such as Text Editor. 

• Monitor your print jobs. 

• Pause, resume or cancel print jobs. 

 

Printer Setup 
Adding a Printer 

1. Open System>Administration>Printing from the desktop 
menu. 
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2. The printer configuration utility will open. Double click the New 
icon to add a new printer. 

 

3. The printer configuration utility will then look for connected 
printers and printer ports. Select the printer you want to install 
and click on the Forward button. 
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4. The printer configuration utility will search for the proper printer 
drivers (software) for your printer. It may find the drivers and 
install them automatically or it may ask you to select the printer. 

 

5. Select the model of printer and click on the Forward button. 
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6. Apply the changes and your printer is set up. 

 

7. Print a test page to test your printer settings. 

 

 

Note: Suppose you have more than one printer available. The default 
printer is the printer that will automatically be offered to you when you 
wish to print. Other printers have to be specifically selected. 

 

Print Outputs 
Print a document from a text editing application 

1. To print from Text Editor, first open the document you want 
printed. Then click on File>Print from the Text Editor window. 

  



56 
 
 

 

 

2. Select a printer from the Print dialog box that opens. Choose 
which pages you wish to print and the number of copies, and then 
click the Print button. 

 

3. Adjust Print range and Copies, if necessary. 

4. Click OK. 

 

View a print job’s progress using a desktop print manager 
Print manager is a utility that lets you view the print jobs in progress and 
to cancel or pause them if necessary. To open the print manager: 

1. Open System>Administration>Printing from the desktop 
menu. 
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2. Click on the printer you sent the print job to and then .choose 
Printer> View Print Queue from the menu. 

 

3. When the Print Queue opens, you can see the print jobs in 
process. 

 

4. You can manage the print job by choosing Job from the menu 
and clicking on the appropriate choice: 

 
• Cancel will cancel the print job in progress 

• Hold will pause the print job in progress 

• Release will resume a print job that is being held 

• Reprint will start the print job from the beginning 
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Summary 

In this section, you learned how to: 

• Set up a printer in Ubuntu. 

• Print documents from an application such as Text Editor. 

• Monitor your print jobs. 

• Pause, resume or cancel print jobs. 
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Module summary 

 

 

In this unit you learned: 

 The main features of the Ubuntu operating system 
including how to adjust the main computer settings and use 
built-in help features. 

 How to operate effectively around the computer desktop 
and work effectively in the GNOME graphical user 
environment. 

 The main concepts of file management and how to 
efficiently organise files and folders so that they are easy to 
identify and find. 

 How to use utility software to compress and extract large 
files. 

 How to use simple text editing and print tools available 
within the operating system. 

 How to set up and monitor a printer in Ubuntu. 
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